5ちゃんねる ★スマホ版★ ■掲示板に戻る■ 全部 1- 最新50  

■ このスレッドは過去ログ倉庫に格納されています

【ALSA】サウンドドライバ総合スレ【OSS】

1 :login:Penguin:04/01/27 22:25 ID:3QULAuCp
サウンドドライバの話題、質問などをどうぞ。

前スレ
http://pc.2ch.net/test/read.cgi/linux/1012998650/


2 :login:Penguin:04/01/27 22:30 ID:eZpwZV4H
ALSA
http://www.alsa-project.org/
http://alsa.linux.or.jp/

Open Sound System
http://www.opensound.com/oss.html

3 :login:Penguin:04/01/27 22:33 ID:JghzbDS7
ALSA のハードウェア対応状況
http://www.alsa-project.org/alsa-doc/

4 :login:Penguin:04/01/27 22:34 ID:JghzbDS7
ALSA ドライバインストールガイド日本語訳
http://www.linux.or.jp/JF/JFdocs/alsa-install.html

5 :login:Penguin:04/01/27 22:37 ID:JghzbDS7
OSS/Free のハードウェア対応状況
http://www.linux.org.uk/OSS/

6 :login:Penguin:04/01/27 22:39 ID:JghzbDS7
ALSA 設定ドキュメント(CVS)
http://cvs.sourceforge.net/viewcvs.py/alsa/alsa-kernel/Documentation/ALSA-Configuration.txt

ALSA OSS互換設定ドキュメント(CVS)
http://cvs.sourceforge.net/viewcvs.py/alsa/alsa-kernel/Documentation/OSS-Emulation.txt

(text) をクリックすると読むことができます。

7 :login:Penguin:04/01/27 22:42 ID:JghzbDS7
質問のコツ

サウンドカードやマザーボードの製品名や型番を書くのではなく、
それらに搭載されているサウンドチップ名を書きましょう。

サウンドチップは以下の方法で調べることができます。

# lspci
# cat /proc/pci

「Multimedia audio controller」などと書かれている行が
サウンドチップについての情報です。

8 :login:Penguin:04/01/27 22:56 ID:JghzbDS7
The ALSA Wiki
http://alsa.opensrc.org/

9 :login:Penguin:04/01/28 01:00 ID:fw9RMMLX
ここの過去ログにvid,pidを0xをつけて書くことを教わったので記念 /etc/modules.conf 。

複数カード(USB-audio二つを含む)を自在にロードできるようになった気がする。
index,vid,pidのカンマの打ち方がミソね。OSSの方は略するけど、dsp_mapとかで遊ぶのかな?
他参考文献: ttp://www.gentoo.org/doc/ja/alsa-guide.xml

# ALSA native device support
alias char-major-116 snd
options snd major=116 cards_limit=3
# オンボードチップ
alias snd-card-0 snd-intel8x0
options snd-intel8x0 index=0
# 0499:3103なUSB-Audioと 0582:0009なUSB-MIDIインターフェースカード
alias snd-card-1 snd-usb-audio
alias snd-card-2 snd-usb-audio
options snd-usb-audio index="1,2" vid="0x0499,0x0582" pid="0x3103,0x0009"

10 :login:Penguin:04/01/28 01:28 ID:s7/K052L
>>9
おぉ、ちょうどUSBサウンド関連の機器を2つ持っていて
(041e:3020なUSB Audioと0499:1001なMIDIインターフェース)
USB Audioを最初に割り当てるためにUSBのつなぎ順とか変えていたのだが
こういう方法があったのだな

さんくすこ>>9

11 :login:Penguin:04/01/28 20:59 ID:Vl9U0bdN
メモ:
440MX、システムバス100MHzの人はハードがバグってます
ごしゅーしょーさま

12 :login:Penguin:04/01/29 10:09 ID:RwxKCNx4
新しいALSA BTSキター
http://bugtrack.alsa-project.org/alsa-bug/

13 :login:Penguin:04/01/29 14:58 ID:ariJMPmm
>* intel8x0
>- added the workaround for a hardware bug in intel 440MX B-stepping
ヤター!と思って試したけど同じように氏にますた…(´・ω・`)ショボーン
別の問題もあるのかのう…(´・ω・`)ショボボーン

14 :login:Penguin:04/01/29 16:23 ID:6u/4hdGN
あのー初歩的な疑問ですが
alsa-driver-1.0.2.tar.bz2
alsa-lib-1.0.2.tar.bz2
alsa-utils-1.0.2.tar.bz2
の順にインスコする方法は様々なサイトで報告されているので分かるのですが
alsa-tools-1.0.2.tar.bz2
ってどうやって扱えばよろしいのでしょうか?この活用方法が知りたいです。

あと alsa-driver の ./configure のときに
使用するドライバをオプション指定で明示しないと使えないのでしょうか?

15 :login:Penguin:04/01/29 17:32 ID:nIvEzflt
>>14
toolsは別に無くても困らないような。

16 :login:Penguin:04/01/29 17:39 ID:nIvEzflt
>>14
明示しないで実行すると全てのモジュールを作ってくれます。

17 :login:Penguin:04/01/31 12:31 ID:scZj3mzD
1.0.2a driver release

18 :login:Penguin:04/02/03 00:53 ID:p/emivL5
2.6には関係なし?

19 :login:Penguin:04/02/03 20:41 ID:Ugmw9mba
1.0.2b driver release

20 :login:Penguin:04/02/03 23:00 ID:DDCan5ky
まぢか
1.0.2aを手パチして2.6.2-rc3に組み込んだばっかなのに

21 :login:Penguin:04/02/04 10:38 ID:VA/FX/mj
んげっ。


22 :login:Penguin:04/02/05 10:54 ID:kFCh1w8y
1.0.2c driver 出てる

23 :login:Penguin:04/02/05 16:02 ID:imnmcIXZ
うわーん。


24 :login:Penguin:04/02/06 16:10 ID:sPzuahHm
bk更新された。

25 :login:Penguin:04/02/07 12:36 ID:+kkUxfe7
今度でるKernel-2.6.3では久々にALSAが大幅にアップデートされるようだが、何か情報ないか?

26 :login:Penguin:04/02/12 18:33 ID:R4p2l8Is
カーネルスレで聞いたらいかが?

27 :login:Penguin:04/02/13 16:26 ID:JntsAdn7
もちついたようだね

28 :login:Penguin:04/02/14 15:15 ID:YKYRElrU
質問させていただいていいですか?
ウチのシステム(RedHat9)ではサウンド関係がうまく動きません。
sncconfigではうまく設定できたような終り方をしますが、
flash playerでは音楽が一オクターブ上がってブツ切れで再生され、
realplayer8では、"Cannot open the audio device. Another application may be using it"
と表示されて再生ができません。
xmmsではうまく再生できます。
サウンドデバイスはこれです。

00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] SiS7012 PCI Audio Accelerator (rev a0)

どのように設定すれば、動くようになりますか?

29 :login:Penguin:04/02/14 16:55 ID:ICJLIrFG
>>28
デスクトップ環境はデフォルトのGNOMEですか?
その場合はサウンドデバイスをesound(esd)が
使っている可能性があります。

>xmmsではうまく再生できます。
XMMSの出力設定は何になっていますか?
esoundになっているなら realplayerの設定を
esound経由の出力に変更しましょう。

30 :login:Penguin:04/02/14 17:53 ID:YKYRElrU
>>29
Desktopはgnomeです。
esdが起動されてなかったようなので、バックグラウンドで動かしました。
realplayerの設定をesoundにしたら、動きました。
おまけにflashplayerの音楽も正常に再生されるようになりました。

ご教授ありがとうございます。

31 :login:Penguin:04/02/18 23:33 ID:1Rt210sv
オーディオの設定について助けを戴きたいです。
最近Redhat9をインストールして、音楽を聴きたいとおもっています。
しかし、esound経由で音が出ない症状に悩んでいます。
<状況>
チップセット(KT266A)内蔵のサウンドチップで、Alsaは使用していない。
alias sound-slot-0 via82cxxx_audio

Redhat附属の設定ツール(redhat-config-soundcard)では音が出る
(たぶんesound経由ではない)。またxmmsの出力先をOSSにすれば音が出るが、
eSoundにすると一瞬音が再生された後音が出なくなる。
gnomeでの効果音は再生されるようです。

32 :login:Penguin:04/02/20 00:45 ID:yD533Y7Y
mp3 ?

33 :login:Penguin:04/02/20 01:44 ID:8H2lrGp7
質問です。
Fedora Core 1 に Kernel 2.6.2 をソースコンパイルでインスコしました。
ALSA を有効にし、サウンドカードのドライバモジュールも組み込みました。
現在ドライバモジュールもきちんとロードされていています。

ところが、良く考えたら alsamixer がインストールされていないんです。
しょうがないので apt-get install gnome-alsamixer しました。
(依存の関係で alsa-lib のパッケージも入りました、ついでに xmm-alsa も。)

そんなこんなでとりあえず「xmmsで音がmp2がちゃんと再生できる」環境にはなってます。

質問1
alsamixer や gnome-alsamixer をインストールせずに mixer の設定を変更すること
はできますか?

質問2
にたような環境の方(ALSA有効2.6系カーネルのソースビルド)の方
alsa-lib、alsa-utils をどうやって入れましたか?(rpm or ソースから)

よろしくおながいします。

34 :33:04/02/20 01:49 ID:8H2lrGp7
つけたしです。

カーネルインスコ後に、サウンドデバイス(?)が見付からなかったので、
alsa-driver のソースを make し、snddevices を実行しました。
この辺りもスマートなやり方があればアドバイスおねがいします。

35 :login:Penguin:04/02/25 04:09 ID:en/zI7Nk
ビルドできない。include/byteeorder/swab.hとかでsyntax errorを起こしてしまう。

36 :35:04/02/25 05:44 ID:en/zI7Nk
>34ね。
あと、カーネルソースの中の
scripts/MAKEDEV.snd
で大丈夫だったと思う。

37 :33:04/02/26 02:08 ID:63ecdFCB
>>36
なんてこった、そんなところにスクリプトがあったんですね。
一応alsa-driverに含まれてるものと中身を比較しましたが、これでいけますね。
34の件はこれで解決です。ありがとうございました。

38 :35:04/02/26 07:01 ID:ZibDk9gV
>37
alsa-libをビルドできたら教えてください。

39 :login:Penguin:04/02/26 09:50 ID:s2KMViyR
みんな kernel2.6 のノウハウをもっとまとめてくれないかな。
http://linux2ch.bbzone.net/index.php?%5B%5BKernel_2.6_FAQ%5D%5D

40 :33:04/02/28 02:52 ID:BEeikNbb
>>38
インストール記録はこんな感じです。
(実際は Kernel 2.6.x 環境のビルド成功後に全て make uninstall しましたが)

# wget ftp://ftp.alsa-project.org/pub/driver/alsa-driver-1.0.2c.tar.bz2
# wget ftp://ftp.alsa-project.org/pub/lib/alsa-lib-1.0.2.tar.bz2
# wget ftp://ftp.alsa-project.org/pub/utils/alsa-utils-1.0.2.tar.bz2
# wget ftp://ftp.alsa-project.org/pub/tools/alsa-tools-1.0.2.tar.bz2

# tar jxvf alsa-driver-1.0.2c.tar.bz2
# cd alsa-driver-1.0.2c
# ./configure --with-cards=ens1371,ens1370 --with-oss=yes --with-sequencer=yes
# make -j2
# make install

* --with-cards=自分のサウンドカードにあったもの。
* -j2 オプションは SMP なのでつけてみただけ。

# tar jxvf alsa-lib-1.0.2.tar.bz2
# cd alsa-lib-1.0.2
# ./configure
# make -j2
# make install

# tar jxvf alsa-utils-1.0.2.tar.bz2
# cd alsa-utils-1.0.2
# ./configure
# make -j2
# make install

>>33でも書いてる通り、gnome-alsamixer を apt で入れたので alsa-lib はパッケージでも入っちゃってますがw

41 :login:Penguin:04/02/28 17:52 ID:fHjmnGbX
alsaがつかえません。
alsa をrpmから installした場合defaltで
alsa driverのフォルダーはどこに作られるのですか?

42 :login:Penguin:04/02/28 18:12 ID:2lxq/Vmp
>>41
rpm -ql alsa-driver

43 :login:Penguin:04/02/29 17:47 ID:R1VCy3aN
1.0.3rc2、出てたのか…

44 :初心者:04/02/29 19:24 ID:2rg5Q6A3
RedHat9.0を使っていて、オーディオデバイスの検出をおこなうと、
ベンダー Intel Corp.
モデル 82801CA/CAM AC'97 Audio
モジュール disabled
と表示されます。これは、ALSAで音を出すことが可能でしょうか。
webのHPを参考にしたのですが、なかなかうまくいきません。
教えて頂けると幸いです。宜しくお願いいたします。

45 :初心者:04/02/29 20:50 ID:2rg5Q6A3
たびたびすみません。いくつか試しているうちにインストールまでは出来ました。

初回設定だったので
# cd /tmp/alsa-driver-0.9.0rc6/utils
# ./alsaconf

を実行してみたら

Loading driver...
Starting sound driver: snd-intel8x0 /lib/modules/2.4.20-8/kernel/sound/pci/snd-intel8x0.o: init_module: No such device
Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
You may find more information in syslog or the output from dmesg
/lib/modules/2.4.20-8/kernel/sound/pci/snd-intel8x0.o: insmod /lib/modules/2.4.20-8/kernel/sound/pci/snd-intel8x0.o failed
/lib/modules/2.4.20-8/kernel/sound/pci/snd-intel8x0.o: insmod snd-intel8x0 failed
done
Setting default volumes...
Saving the mixer setup used for this in /etc/asound.state.
/usr/sbin/alsactl: save_state:1048: No soundcards found...
===============================================================================

Now ALSA is ready to use.
For adjustment of volumes, please use alsamixer or gamix.

Have a lot of fun!
サウンドカードがみつける方法をみつけた方法を御存じの方、
教えて頂けると幸いです。宜しくお願いいたします。

46 :初心者:04/02/29 20:50 ID:2rg5Q6A3
たびたびすみません。いくつか試しているうちにインストールまでは出来ました。

初回設定だったので
# cd /tmp/alsa-driver-0.9.0rc6/utils
# ./alsaconf

を実行してみたら

Loading driver...
Starting sound driver: snd-intel8x0 /lib/modules/2.4.20-8/kernel/sound/pci/snd-intel8x0.o: init_module: No such device
Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
You may find more information in syslog or the output from dmesg
/lib/modules/2.4.20-8/kernel/sound/pci/snd-intel8x0.o: insmod /lib/modules/2.4.20-8/kernel/sound/pci/snd-intel8x0.o failed
/lib/modules/2.4.20-8/kernel/sound/pci/snd-intel8x0.o: insmod snd-intel8x0 failed
done
Setting default volumes...
Saving the mixer setup used for this in /etc/asound.state.
/usr/sbin/alsactl: save_state:1048: No soundcards found...
===============================================================================

Now ALSA is ready to use.
For adjustment of volumes, please use alsamixer or gamix.

Have a lot of fun!
サウンドカードがみつける方法を御存じの方、
教えて頂けると幸いです。宜しくお願いいたします。

47 :login:Penguin:04/03/01 01:39 ID:MclhUmIB
1.0.3 age

48 :login:Penguin:04/03/02 00:25 ID:tjUZ4HP3
サウンドドライバが認識されずシステムBeep音のみぞといふマシンもまたをかし。

49 :login:Penguin:04/03/02 00:36 ID:2l5Hw7s4
>>46
>You may find more information in syslog or the output from dmesg
とあるからdmesgかtail /var/log/messagesとかしてエラーを見るよろし。

PCIチップなら特に設定いらないはずだから、BIOS設定見直すとか
カーネルのAPIC有効にしてみるとか。

50 :名無しさん@Vim%Chalice:04/03/02 03:23 ID:fTWqJaEw
質問です。

alsa自体のインストールはできたのですが肝心のボリューム調整ができません。
具体的にいうと alsamixer を起動したとき、
PCM のところだけボリューム調整ができません。
本来ボリュームの値のあるべきところに何も表示されません。
そして当然のように音も出ません。

インストールは
http://www.alsa-project.org/alsa-doc/doc-php/template.php?company=Intel&card=i820E&chip=i820E&module=intel8x0
を参考にしました。

cat /proc/pci | grep audio
とすると
Multimedia audio controller: Intel Corp. 82801DB AC'97 Audio Controller (rev 2).
となりました。

51 :login:Penguin:04/03/02 08:58 ID:H6wTmg9g
>>50
とりあえずsyslogとかに怪しいメッセージが出ていないかどうか
調べてみたら?

52 :login:Penguin:04/03/02 12:56 ID:gfIux19c
/etc/modules.confを晒してみたら?

うちは、
Multimedia audio controller: Intel Corp. 82801DB AC'97 Audio Controller (rev 2).
だけど、ちゃんと大丈夫だよ。


53 :名無しさん@Vim%Chalice:04/03/02 15:40 ID:fTWqJaEw
>51
調べてみましたら、
modprobe: modprobe: Can't locate module char-major-10-134
と言うエラーがありましたが、関係あるのでしょうか。

>52
modules.conf には、>50 で参考にしたサイトのものをまるまる写しました。
写したところだけ抜粋すると

# ALSA portion
alias char-major-116 snd
alias snd-card-0 snd-intel8x0
# module options should go here

# OSS/Free portion
alias char-major-14 soundcore
alias sound-slot-0 snd-card-0

# card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss

となります。

54 :hoge:04/03/02 23:15 ID:xbBoR/xk
FedoraCore1で,kernelを2.6.3にしたらsnd-emu10k1が自動で読み込まれなくなりました。
読み込まれるのは,snd,sndcore,snd_mixer_ossだけです。
modprobe snd-emu10k1 とすれば問題なく音が出るようになりますが,modules.confに期待したとおりではありません。
どうすれば,自動で読み込まれるようになりますか?

/etc/modules.confには,

alias char-major-116 snd
alias char-major-14 sndcore
alias snd-card-0 snd-emu10k1
post-install snd-card-0 /usr/sbin/alsactl restore >/dev/null 2>&1 || :
alias sound-slot-0 snd-card-0
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss

と書いています。

55 :33:04/03/02 23:30 ID:E/gZrdov
>>54
うちは Fedora で kernel 2.6.3-ck2 使ってます。(kernelはソースからビルド)

/etc/modprobe.conf

include /etc/modprobe.conf.dist
...
alias snd-card-0 snd-ens1371
alias sound-slot-0 snd-ens1371
...

kernel 2.6系 は modprobe.conf みたいですよ。
http://japan.linux.com/kernel/03/09/17/1114241.shtml

56 :初心者:04/03/03 19:44 ID:nPekf6yp
>>46
ありがとうございます。Intel845MPチップセットを利用してるので、エラーメッセー
ジを参考にBIOS設定、カーネルのAPICを直してみます。どうもありがとうございまし
た。

57 :たけし:04/03/03 21:00 ID:TEeocJNe
最近 fedora core をインストールしましたがサウンドカードは
認識しますが音が出ません。
alsaを入れようとしてみますが以下のところでつまずきます。
どうしたらよいかお教願います。

[takeshi@localhost alsa-driver-0.9.4]$ ./configure
checking for gcc... no
checking for cc... no
checking for cc... no
checking for cl... no
configure: error: no acceptable cc found in $PATH


58 :login:Penguin:04/03/03 21:02 ID:6VBSAx7Y
・・・。

59 :login:Penguin:04/03/03 21:03 ID:1AzRauFi
基本的なエラーメッセージ読めないは(・∀・)カエレ!!

60 :hoge:04/03/03 21:18 ID:s7eiSpjX
>>55
おかげさまで,うまくいきました。ありがとうございました。

/etc/modprobe.confの抜粋
alias char-major-116* snd
alias snd-card-0 snd-emu10k1
alias char-major-14* soundcore
alias sound-slot-0 snd-card-0
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
install snd-card-0 /sbin/modprobe --ignore-install snd-card-0 && { /usr/sbin/alsactl restore >/dev/null 2>&1 || :; }
install sound-slot-0 /sbin/modprobe --ignore-install sound-slot-0 && { /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1 || :; }


61 :login:Penguin:04/03/03 21:41 ID:Z4N3uI20
>>57
チョットワロタ

no ---> _no ---> _| ̄|○

62 :login:Penguin:04/03/03 21:51 ID:+ppINsE5
そんなこというとconfigureでnoといわれるたびに_| ̄|○に見えるように...

63 :login:Penguin:04/03/03 22:55 ID:GnnB2MsM
ぶっはははは。
ひさびさに笑った。


64 :login:Penguin:04/03/04 01:07 ID:4ko2WwEY
うぅ..音が出ない..
モジュールのロードはできていて、alsamixerも起動するんだけど…
VIAのVT8235でちゃんと音なってるひといます?ちなみに、Verは1.0.2

65 :login:Penguin:04/03/04 01:18 ID:B5yw39H1
mute は外した?
ハードウェア直轄のサウンド・ボリュームのほうの mute も

66 :64:04/03/04 02:57 ID:4ko2WwEY
ミュートは全部外してあります。。。
つか、なんかalsaにしたら不安定。ほんとなんでだろう…

67 :64:04/03/04 04:01 ID:4ko2WwEY
AudioCDは聞ける…何なんだいったい?
ちなみにalsaconfのテストの音声は聞けませんでした。。。

68 :login:Penguin:04/03/04 04:04 ID:B5yw39H1
> alsaconfのテストの音声は聞けませんでした
モジュールが正しくないかと

69 :64:04/03/04 17:20 ID:4ko2WwEY
マザーはP6VEMD チップ名はVT8235

cat /proc/pciの結果は
Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235 AC97 Audio Controller (rev 80)

cat /etc/modules.conf
alias char-major-116 snd
alias char-major-14 soundcore
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
alias snd-card-0 snd-via82xx
alias sound-slot-0 snd-via82xx

間違ってます?
参考 ttp://www.alsa-project.org/alsa-doc/doc-php/template.php?company=VIA&card=&chip=via8235&module=via82xx

70 :login:Penguin:04/03/04 18:58 ID:xGOqU42Z
漏れのノート。

alias char-major-116 snd
options snd major=116 cards_limit=1
alias snd-card-0 snd-via82xx
post-install snd-card-0 alsactl restore
alias char-major-14 soundcore
alias sound-slot-0 snd-card-0
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss

71 :64:04/03/04 22:10 ID:4ko2WwEY
>>70
Thanks 試して見たけどだめだった。
MixerでMicのミュート外すとブツって音するし、CDは聞けるんだから壊れては
いないんだろうけど。OSSエミュレーションあたりが悪いのかな?

72 :64:04/03/05 20:12 ID:EbBY8NsC
結局、Via公式のドライバ(OSS)を使って音鳴らしました。
そのうちまた挑戦します;;

73 :login:Penguin:04/03/07 18:19 ID:vu1DecNq
>64
gigabyte ga-7vax で問題なくできたよ。

74 :73:04/03/07 18:26 ID:vu1DecNq
>64
今の環境はVT8235(ALC650)でlinuxは
kernel-2.6.4-rc1,alsa-lib-1.0.2なんだけど、
ドライバはカーネル付属のものでとりあえず
modprove snd-via82xx
alsamixer でミュートを外せば
alsaでもOSSエミュレーションでも問題なく音がでます。
modules.confにもmodprove.confにも何も書かなくても音はでます。
確認したのはxmmsとxineとbmp。

75 :login:Penguin:04/03/08 06:58 ID:iBW+XsjG
>>48
アハハ、それ私の。
PCMCIAカードを入れるとピッピッっていうけど、それ以外はウンともスンとも。
頑張ります。

76 :76:04/03/10 08:23 ID:2uUJturX
$ gnome-sound-recorder &
とした際に、スピーカから自分の声は聞こえるのですが、音は録音されず、下のエラーメッセージが出てしまいます。
** (gnome-sound-recorder:4016): WARNING **: couldn't set requested OSS parameters, enjoy the noise :)
このときの時の対処方法をご存知でしたら、教えてください。宜しくお願い致します。

77 :login:Penguin:04/03/11 00:45 ID:nr9dx0ZO
esdが非常にあやちい

78 :login:Penguin:04/03/11 02:15 ID:nr9dx0ZO
3D control centerをOFFにするとノイズが無くなった。

79 :login:Penguin:04/03/14 19:21 ID:P4WO55AY
サウンドカード二枚ざしでそれぞればらばらに同時録音ってのは
可能なんでしょうか?


80 :login:Penguin:04/03/14 19:25 ID:P4WO55AY
下げ忘れた
スマソ


81 :79:04/03/15 11:14 ID:XZ+ME5xa
もっと具体的に書きますね。
ALSAのドライバを使って、サウンドカード二枚挿しし、
それぞれのLin-inにそれぞれちがう音源を入力します。
同時に録音してマクロで自動的に録音を考えています。
これは可能なんでしょうか?

使うPCは
RedHat linux 9

使うサウンドカードは
Soundblaster PCI 128 CT4750

チップセット:?(ちなみに、チップにはCT5880とかいえてあり、[#lspci]
と「#cat /proc/pci」の結果にはEnsoniq 5880 AudioPCIと
書いてあるのですが・・・?)

Aoundblaster PCI CT5806
チップセット:?(チップにはES1373とあり、[#lspci]と「#cat /proc/pci」
の結果にはES1371とある・・・?)

どちらにせよ対応はしているようなのでALSAをこれからいれようと
思うんですが・・・。

結局のところ、上記のことはできるのでしょうか?






CT5806
ES1373

82 :login:Penguin:04/03/15 11:20 ID:baUUF4zu
>>81
arecord とかは録音デバイスを指定できるように
なっているみたいだからできるんじゃないの?
つか、そういうことやったことがないから
人柱で挑戦キボン

83 :79:04/03/15 11:28 ID:XZ+ME5xa
よっしゃ
人柱になります
ずいぶんともろい柱なんでご協力お願いします。


84 :79:04/03/15 11:32 ID:XZ+ME5xa
現在

ttp://www2h.biglobe.ne.jp/~hnakamur/technolab/linux/sound/alsa.htm

を参考に久しぶりにlinuxを動かしております。
腹が減ってきますた。

85 :login:Penguin:04/03/15 13:10 ID:PChrhBv2
>> 79,81
> これは可能なんでしょうか?
可能です.当方は,emu10k1の2枚刺しですが,modules.confに,
alias char-major-116 snd
alias char-major-14 soundcore
options snd major=116 cards_limit=4
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
alias snd-card-0 snd-emu10k1
alias sound-slot-0 snd-card-0
alias sound-service-1-0 snd-mixer-oss
alias sound-service-1-1 snd-seq-oss
alias sound-service-1-3 snd-pcm-oss
alias sound-service-1-8 snd-seq-oss
alias sound-service-1-12 snd-pcm-oss
alias snd-card-1 snd-emu10k1
alias sound-slot-1 snd-card-1
alias /dev/dsp* snd-pcm-oss
options snd major=116 cards_limit=2 device_mode=0666 device_gid=0 device_uid=0
options snd-emu10k1 index=0,1 id=CARD_0,CARD_1
と設定し,
arecord -f cd -D hw:0 -t wav test0.wav &
arecord -f cd -D hw:1 -t wav test1.wav
で録れてます.

86 :79:04/03/15 13:24 ID:XZ+ME5xa
>>85
レスありがとうございます
ちょっと飯のため席をはずしておりました
ものおっつありがたいです!!
confをいじるまで到達していないので、
とりあえずそこまで追いつきます


87 :79:04/03/15 15:24 ID:XZ+ME5xa
久しぶりにいじるので時間がかかるです・・・
とりあえず、modules.confをいじるまで行きました。
ttp://shino.pos.to/linux/alsa.html
85氏のを参考にちょっといじくってます・・・
ちなみに、今現在のmodules.confは

alias eth0 e100
alias usb-controller ehci-hcd
alias usb-controller1 usb-uhci
alias sound-slot-0 es1371
post-install sound-slot-0 /bin/aumix -f /etc/.aumixrc -L >/dev/null 2>&1 || :
pre-remove sound-slot-0 /bin/aumix -f /etc/.aumixrc -S >/dev/null 2>&1 || :

88 :79:04/03/15 15:40 ID:XZ+ME5xa
と、modules.confの設定を変えねばならないらしいので、

ttp://www.susono.com/~norio/linux/media/alsa_setup.html

を参考に設定
aptで設定すると楽だなぁ
とおもた

89 :79:04/03/15 16:01 ID:XZ+ME5xa
優先すべき仕事が入ったんで、明日に続きします〜
では、またのちほど〜

90 :85:04/03/15 19:56 ID:PChrhBv2
何だか,私のmodule.confは,3行目と下から2行目が
> options snd major=116 cards_limit=4

> options snd major=116 cards_limit=2 device_mode=0666 device_gid=0 device_uid=0
で,重複している.(笑)
動いているから気づかなかったけど,たぶん3行目はなくてもいいと思う.
(今,ちょっと試せないです.)

以下には,3枚の事例があります.
ttp://www.heart-pot.co.jp/alsa.html


91 :login:Penguin:04/03/17 12:20 ID:v9qQE3co
>>58のたけしくん、自殺してなきゃいいけど。

92 :91:04/03/17 12:21 ID:v9qQE3co
>>57だった

93 :79:04/03/17 17:08 ID:mKP9hxpj
ただいまもどりますた

>>85
毎度ありがとうございます。
参考になります!!

人柱をまた続けます。
ちょっと仕様が変わりました。

Sound blaster Live Value!
チップセット:EMU10k1

Soundblaster PCI 128 CT4750
チップセット:5880(?)
(前回と同じやつです。ちなみに、調べによるとSoundblaster PCI 128はロットによって
石が変わるらしいです。
だからもしかすると、CT5880と認識されてる恐れもあります。
ちょっとそれも含めてチャレンジします

↓参考
ttp://www.susono.com/~norio/linux/media/alsa_setup.html)

どうでもいい話ですが、タイムリミットが明日までなので、けっぱって
やります!!
では、またのちほど

94 :login:Penguin:04/03/17 21:19 ID:K4a41PqF
alsaの設定を1から御教授されたい…

2.4/2.6系 kernel config … Mチェックはサポートとドライバだけでいい?

/etc/rc.d/rc.modules … depmod と alias 、/dev/* の関係が分からない…

/etc/modules.conf … /lib/modules/2.x.x/ 下のどれをどのように指定すれば良いのか?

95 :login:Penguin:04/03/17 21:56 ID:7dHGq6+t
> alsaの設定を1から御教授されたい…

日本語喋れ!
まずはそれからだ。


96 :login:Penguin:04/03/17 22:16 ID:K4a41PqF
>>95
音が鳴りません。alsaの設定を初めから詳しくお教え下さい。

97 :login:Penguin:04/03/17 22:34 ID:o8r9yXZR
alsaconf

98 :login:Penguin:04/03/17 22:42 ID:hswvN6tn
どうぞ。
http://www.alsa-project.org/

まずはサウンドカードのメーカと型番を調べる.型番とlinuxを
検索キーワードにしてgoogleで検索する.
http://www.google.co.jp/

99 :login:Penguin:04/03/17 22:42 ID:K4a41PqF
% alsaconf
zsh: command not found: alsaconf

100 :login:Penguin:04/03/17 23:03 ID:a5Gda2uz
>>96
>>6

101 :login:Penguin:04/03/18 05:49 ID:eBbnAa3v
94=たけしくん

102 :takasi:04/03/18 13:18 ID:qcoEwmev
どうも、こんにちわ。
すみません。質問があります。
UMLをbusybox1.00pre7があるファイルシステムで動かしてるのですが、Ctrl+C,Z等でプロセスが停止できません。
いろいろと調べてみましたが少々力不足でわかりません。
とりあえずsttyで調べたところintr、suspの設定に不備はありませんでした。
また、FDを使ったLinuxシステムではbusybox1.00pre7でも問題なく動いてます。
シェルがおかしいらしいんですが、どうも自分ではわかりません。
だれか解決策を知っている方がいましたら教えてください。
ちなみにカーネルは2.4.20-8です。

103 :login:Penguin:04/03/18 14:50 ID:pNx8d7eR
cd 聞くのにalsa使って、tvチューナーボードの音聞くのに
oss使うってできますか?


104 :login:Penguin:04/03/18 19:26 ID:qnC01c7u
出来る。
アプリ次第だけど、設定でどうにでもなるやろ。


105 :login:Penguin:04/03/19 00:21 ID:W6AC66Du
CD はミキサで音量変えるだけで聞ける
alsa は OSS のデバイスを用意している
というのが解だな

106 :login:Penguin:04/03/19 01:04 ID:phA179KG
alsaconf の全部の選択肢を試しても音が鳴りませんでした。
どうすれば良いですか?

107 :login:Penguin:04/03/19 01:08 ID:eSZAQ3M3
カード変えたら?


108 :login:Penguin:04/03/19 01:17 ID:phA179KG
on board です。具体的には note PC です…

109 :login:Penguin:04/03/19 03:27 ID:xr1qg3Ss
ちゅうかlspciくらい晒せや

110 :login:Penguin:04/03/19 07:57 ID:eSZAQ3M3
note pc だけで分かるか!ぼけっ!


111 :103:04/03/19 11:25 ID:mYU1mzeh
>>104 >>105 サンクス
>>106
ac97 codecとかなってない?

112 :login:Penguin:04/03/19 11:33 ID:4JM9PwOS
>>106,108
>>7 読んで質問の仕方を変えましょう。
キミの質問の仕方は以下のなぞなぞと同じようなものだよ。

「昨日ノートパソコン買ってきました。さて機種は何でしょう?」

113 :login:Penguin:04/03/19 18:49 ID:qMqdqVYz
102

たけしくんの弟のたかしくんですか?
とりあえず、きみの姉貴の写真のうp。話はそれからだ。

114 :login:Penguin:04/03/19 22:36 ID:g2yxg41Q
音が鳴ったァ━━━(。A。)━━━ッ!!!!!

115 :login:Penguin:04/03/19 22:49 ID:wjGgCHb6
おめっとさーん

116 :login:Penguin:04/03/20 05:40 ID:PAVPng+L
How to install DKMS ALSA Packages for Fedora
http://fedoranews.org/tchung/dkms/
DKMSって初めて聞いた。カーネルに合わせてドライバをコンパイル、インストールしてくれるツール?


117 :login:Penguin:04/03/20 17:16 ID:Ow8L1UAv
alsa diver入れたんだけど、マシン再起動すると音がでなくなります。
そのたびにalsaconfやってるんだけど、面倒くさくて。
なんとかなりませんか?おながいします。

118 :login:Penguin:04/03/20 17:25 ID:W8DutScE
>>117
サッパリ状況がつかめない。
分かることは起動する度にalsaconfをしていることだけ・・。

119 :login:Penguin:04/03/20 17:28 ID:9zswY+Mg
いやだから、再起動すると音がでなくなるんだよ^^;

120 :33:04/03/20 17:55 ID:ypq/Lq5s
>>117
起動時に毎回ミキサーの設定がクリアされているのでは?
音が鳴る時に一度
# alsactl store
して、再起動後音が鳴らない時に
# alsactl restore
してもだめですかね。

121 :117:04/03/20 18:12 ID:9zswY+Mg
33さんどうもです。
そのようにやってみましたところ、奈留様になりました。
有り難う。

122 :login:Penguin:04/03/20 20:16 ID:I0LCHlv/
>>121
今更だけどFAQに載ってる。
http://linux2ch.bbzone.net/pukiwiki.php?FaqHardware#content_1_21

123 :login:Penguin:04/03/20 20:41 ID:3R7Q/SkQ
# alsactl storeは、INSTALL終了時やREBOOT後に実行したALSACONF後にちゃんとしましたよ。
それでもならなくなるので。
# alsactl restoreしたら問題なくなりました。

124 :login:Penguin:04/03/20 23:36 ID:CnOXYXEn
>>123
alsactl store で設定を保存出来ることが判っているのなら、その設定を読み出そうとするのは
自然な考え方じゃないかな。そのへんは調べたの?

125 :login:Penguin:04/03/21 00:08 ID:oiGZXf4i
粘着

126 :login:Penguin:04/03/21 01:20 ID:UgzmRfQh
タコ多すぎ。素直にいうこと聞け、ぼけっ!


127 :79:04/03/21 07:35 ID:nQ8PJWUO
うごかないっす!!!
arecord -f cd -D hw:0 -t wav test0.wav &
arecord -f cd -D hw:1 -t wav test1.wav
のhw:1のほうが録音できないです.なんででしょう...?
modules.confは...

alias usb-controller usb-uhci
alias eth0 3c59x
# --- BEGIN: Generated by ALSACONF, do not edit. ---
# --- ALSACONF verion 0.9.0 ---
alias char-major-116 snd
alias char-major-14 soundcore
alias snd-card-0 snd-emu10k1
alias sound-slot-0 snd-card-0
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
alias snd-card-1 snd-es1371
alias sound-slot-1 snd-card-1
alias sound-service-1-0 snd-mixer-oss
alias sound-service-1-1 snd-seq-oss
alias sound-service-1-3 snd-pcm-oss
alias sound-service-1-8 snd-seq-oss
alias sound-service-1-12 snd-pcm-oss
alias /dev/desp* snd-pcm-oss
options snd snd_major=116 snd_cards_limit=4 snd_device_mode=0666 snd_device_gid=0 snd_device_uid=0
options snd-emu10k1 index=0 snd_id=CARD_0 snd_pbk_frame_size=4 snd_cap_frame_size=4
snd_mic_frame_size=4
options snd-es1371 index=1 snd_id=CARD_1

128 :79:04/03/21 07:42 ID:BrTuJfkS
arecord -d 20 -f cd -D hw:1 -t wav test1.wav

とすると、

arecord: main:480 audio open error; No such device

とでます。ちょっと調べたところ、

ttp://www.linux.or.jp/JF/JFdocs/Sound-HOWTO-6.html#ss6.6

とあったので、カーネルを更新しなければいけないかもしれないと言う
事に・・・しかしながら、いろいろせっかく設定したのに、危険な賭けに
出るのはちょっと怖いです・・・。
何が悪いんでしょうか・・・?

129 :85:04/03/21 09:24 ID:QqDUmLrX
動かない方を,単品ではどうなんでしょうか?
ちょっとググッてみたら,
記事古いですけど,

> これは、巷で評判の、動かないES1371 rev 7ってやつみたいですね。

http://lists.debian.or.jp/debian-users/199911/msg00510.html
http://lists.debian.or.jp/debian-users/199911/msg00513.html

なんてのを見つけました.


130 :79:04/03/21 10:06 ID:BrTuJfkS
たった今,alsaconfを使って設定し、ES1371を単品で動かしました。
ちなみに、私が使ってるES1371は(ver 4)らしいです。
なんでつかえないんだろ・・・?
いまだなぞです


131 :79:04/03/21 10:09 ID:BrTuJfkS
いやはやしかし,85氏は毎度お世話になりっぱなしで・・・
頭が上がらないです・・・ありがとうございます

132 :85:04/03/21 10:53 ID:QqDUmLrX
>>130
> たった今,alsaconfを使って設定し、ES1371を単品で動かしました。
> ちなみに、私が使ってるES1371は(ver 4)らしいです。
> なんでつかえないんだろ・・・?

79さんの使っているバージョンが分んないけど,
optionの変数に使ってあるprefixのsnd_って,最近のは除くようになったんじゃなかったでしょうか?
こんな感じに,

options snd major=116 cards_limit=4 device_mode=0666 device_gid=0 device_uid=0
options snd-emu10k1 index=0 id=CARD_0 pbk_frame_size=4 cap_frame_size=4 mic_frame_size=4
options snd-es1371 index=1 id=CARD_1

snd-es1371の設定だと,以下なんか参考になるんじゃないでしょうか?
http://www.alsa-project.org/alsa-doc/doc-php/template.php?company=Creative+Labs&card=Soundblaster+PCI+128&chip=ES1371&module=ens1371

モジュールをロードする時に何かエラーは出てません?


133 :79:04/03/21 14:22 ID:BrTuJfkS
あちらを立てればこちらがたたず・・・
うまくいかないです・・・。
もしかすると、このやり方の場合、同じサウンドカードを2枚用意
したほうが良いかもしれないですね。
どのサイト見ても同じサウンドボードをつかっている。
emu10k1の石のついたサウンドボードを探してきたほうが早いの
かもしれないのかな・・・?などと思ってみました。
ちょっと時間がないので、完全に85氏と同じ構成にしちゃおうと
思います。
emu10k1の2刺しで行きます。
買い物にいってきマース


134 :79:04/03/24 18:43 ID:DFGcuCwO
人柱です〜
いろいろお世話になりました。一応多チャンネル録音はできるようになりました。
ただ、一つ問題があったせいで失敗していたようです。
カーネルの関係上、ALSAドライバのバージョンが、最新ではないかったので
多数のサウンドカードを使用するときの音のフォーマットがCDの規格(44.1kHz,16bit)
じゃなければ録音できないと言う症状があったようです。
最新のドライバではどこまで対応できているかわかりませんが、寝てなかったので、
そういうことまで考えられませんでした・・・。
本当はそこまでの規格ではなく、もっと低サンプリングレート、低分解能で行きたかった
んですが、結局妥協して、CD規格にしました。
次回はカーネルを最新にしてalsaドライバーを最新にしようと思います。
(それが解決策になるかどうかはわかりませんが・・・。)
ちなみに、同じサウンドカードでなくても大丈夫だったっぽいです。
上記の理由で、動かなかっただけで、同じサウンドカードでなくてもOKだと思います。
しかしながら、同じサウンドボード同士の方がお互いの音の違いがなくていいとは思います。
それぞれの特徴のあるサウンドボードを使って違う音をとるというのであれば、
違うサウンドボードの方式がいいとは思います。

今回は何から何までありがとうございました。
たぶん、ここのスレ無しではたどり着いていないと思います。
とくに、85氏にはお世話になりました。
結局、modules.confは85氏のそのままコピペですし・・・
ホントありがとうございました。


135 :login:Penguin:04/03/31 11:10 ID:3nj9+JN4
いつのまにか1.0.4rc2が出てる。


136 :login:Penguin:04/04/04 03:00 ID:E4CGiLll
1.0.4 キタ━━━━(゚∀゚)━━━━ッ!!

137 :カリパー:04/04/18 09:03 ID:/MCRU83n
はぁぁぁぁぁ・・・・・・・
PCの音が出なくなったぁぁぁぁぁぁぁぁ

138 :login:Penguin:04/04/18 10:58 ID:CYZ/g/mS
>>137

# alsaconf

http://www.google.co.jp/search?hl=ja&ie=UTF-8&oe=UTF-8&c2coff=1&q=%E3%82%B5%E3%82%A6%E3%83%B3%E3%83%89%E3%83%89%E3%83%A9%E3%82%A4%E3%83%90+site%3A2ch.net&btnG=Google+%E6%A4%9C%E7%B4%A2&lr=lang_ja
このスレが一番上。
ヘェー

139 :login:Penguin:04/04/18 21:40 ID:3m8A+pE5
SBLiveで音がならないと、悩んでいたんだけど。チップセットをよく見るとEMU10k1Xでした。
OSSのライセンス料払うぐらいなら、カード買ってきた方がいいのかな?

140 :login:Penguin:04/04/25 02:11 ID:NIdzMiRK
RHL9 Kernel2.4.20-8でインストールは正常にできたのですが、
# /etc/rc.d/init.d/alsasound start
Starting sound driver: snd-via82xx /lib/modules/2.4.20-8/kernel/sound/acore/snd.o: unresolved symbol __write_lock_failed
/lib/modules/2.4.20-8/kernel/sound/acore/snd.o: unresolved symbol kernel_flag_cacheline
/lib/modules/2.4.20-8/kernel/sound/acore/snd.o: unresolved symbol __read_lock_failed
/lib/modules/2.4.20-8/kernel/sound/acore/snd.o: unresolved symbol schedule_work
/lib/modules/2.4.20-8/kernel/sound/acore/snd.o: insmod /lib/modules/2.4.20-8/kernel/sound/acore/snd.o failed
/lib/modules/2.4.20-8/kernel/sound/acore/snd.o: insmod snd-via82xx failed
done
となってしまい機能しません。このエラーを検索してみたら、余り多くは出て来ませんでしたが、このカーネルのバージョンが多かった気がするんだけど関係あるんですかね?

141 :login:Penguin:04/04/25 08:49 ID:WfOna/TW
>>140
ALSA はどうやっていれましたか?
バイナリのRPMから入れたのならRPMの作成環境の
カーネルのバージョンがあなたのマシンのカーネルと違うのかも。
一旦 ALSA をアンインストールしてソースRPMから入れてみるのがいいかも。

違うのなら depmod -a とかしてモジュールの依存関係を作りなおすとか。

142 :login:Penguin:04/04/25 08:49 ID:WfOna/TW
× 一旦 ALSA をアンインストールしてソースRPMから入れてみるのがいいかも。
○ 一旦 ALSA をアンインストールしてソースRPMをリビルドしてそれを入れてみるのがいいかも。


143 :140:04/04/25 11:30 ID:NIdzMiRK
ALSAは1.04をソースからインストールしました。
depmod -a しても同じく依存関係エラーを連発してだめです

144 :login:Penguin:04/04/25 13:38 ID:IGB6+QBe
Kernelのconfigはチェックしました?
kernelのサウンドモジュール(ESD?)が入っているとALSAのモジュールをバッティングします。
ALSAを入れたいならサウンドモジュールを作らないように設定してkernelを再コンパイルする必用があります。



145 :login:Penguin:04/04/25 14:04 ID:x/s9satA
>>144 嘘つき!



146 :login:Penguin:04/04/29 18:31 ID:k6kn2JGN
OSSは2.7で排除される予定なんか

147 :login:Penguin:04/04/29 21:41 ID:txr2B2vt
Slackware9.1+ES1879チップを使っています。
alsaconfでモジュールes18xxを読み込み
認識させるところまではいいのですが、その後
"No legacy cards found"
とメッセージが出てしまいます。
が、音は何故かちゃんと鳴ります。
また、このスレにある通り、
# alsactl store
とやって再起動し、
# alsactl restore
と入力しても、
load_state:1134: No soundcards found...
と出てきて結局先の設定をロードしてくれません。
何がおかしいのか、アドバイスをお願いします。
(音が鳴るようになった直後や、"alsactl store"の後に見てみたのですが、
/etc/modules.conf には何も書かれていませんでした。)

148 :login:Penguin:04/04/29 21:52 ID:vZ7F3+xF
CMI9738がまともに動いてくれるカーネル2.6で利用できるドライバはないものか。
http://www.cmedia.com.tw/product/CMI9738.htm
VIA物のCMI9738を使っているのだが、ボリューム調節するとき少しおかしい。
主音量で調節できないのでVIA DXSという場所をいじってやる必要がある。

149 :login:Penguin:04/05/02 21:05 ID:Yc+45yzt
Kernel-2.4.26でALSA 1.0.4をBuildしようと思ったら、
linux-2.4.26/include/linux/proc_fs.hと
alsa-driver/include/adriver.hでPDEという同一のポインタを定義してて
コンパイルできないでつ。

どうすればいいんでしょうか?


150 :login:Penguin:04/05/03 02:35 ID:RrgN5hJz
いつの間にかvortex系がサポートされているではないか!!
嬉しいのか哀しいのか自分でもようワカラン。

151 :login:Penguin:04/05/08 15:54 ID:HrrHkmA2
asus P4GE-Vのオンボードのサウンドチップ使ってalsaで音出せた人います?
俺やってみたのだけど、よくわからん。

45 KB
■ このスレッドは過去ログ倉庫に格納されています

★スマホ版★ 掲示板に戻る 全部 前100 次100 最新50

read.cgi ver 05.04.00 2017/10/04 Walang Kapalit ★
FOX ★ DSO(Dynamic Shared Object)